Sunday, May 14, 2006

SONY vaio VGN-FS315S and Geforce go 6400 problems

After getting a SONY VAIO VGN-FS315S with the following config:

Intel(R) Pentium(R) M processor 1.86GHz
LCD X-Black15,4 screen with 1280x800 resolution
1024 MB RAM
100 GB Hard drive
DVD-/+RW optical drive
NVIDIA GeForce Go 6400 (128 MB)
Realtek High Definition Audio Soudcard
Intel PRO/100 VE (wired network interface)
Intel PRO/Wireless 2200BG (802.11b/g standards)

I installed Warcraft III Frozen Throne and after half hour of playing, I was getting errors like:

BCCode : 100000ea BCP1 : 855E9810 BCP2 : 843AC848 BCP4 : F7A57CB4
BCP4 : 00000001 OSVer : 5_1_2600 SP : 2_0 Product : 768_1


among with the "System has recovered from a serious error" message.

The same thing was happening in Civilization 4.
In the benchmark and stress programs, all was fine, I was not getting any error. I was in the point of returning the laptop, but I have found one some forums something about new drivers and I gave one more chance.

I downloaded the NVIDIA Forceware 82.10 (x32) drivers from
http://downloads.guru3d.com/download.php?det=1227 and things are much better now, almost no more crashes.

So it was definitely a video card problem, I assume some kind of overheating since it was happening only after some minutes of playing.

1 comment:

Bob said...

I'm having the exact same problem on my sony laptop (VGN-FS790) with the same graphics card. where did you find the suggestion for the NVIDIA forceware 82.1 (x32) driver? Also, on the site for the driver it doesn't list any sony laptops as being compatible.